Linked and Batch Audience Computations may be delayed

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 18:34 PDT

Monitoring

We continue to monitor queue recovery, and expect delays to recover within the hour.
Posted Jul 07, 2025 - 18:04 PDT

Identified

A subset of Linked & Batch Audiences computations are be taking longer than normal to complete.
Posted Jul 07, 2025 - 16:25 PDT
This incident affected: Engage (Engage (US)) and Linked Audiences (Linked Audiences (US), Linked Audiences (EU)).