Delayed Predictive Recommendations and delivery to List Destinations

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 13:09 PDT

Monitoring

Due to rate limiting by our upstream infrastructure vendor, we are seeing delays of 30 minutes in Predictive Recommendations, and in delivery of audiences and computed traits to List Destinations. We are monitoring these delays as they recover.
Posted Jul 11, 2025 - 09:30 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US), Streaming Destinations (EU)).