Delays in event delivery in EU

Incident Report for Segment

Resolved

Delays have fully recovered to real-time. We have seen no indication of any data loss as part of this incident.
Posted Oct 14, 2025 - 15:18 PDT

Monitoring

We have implemented a fix for the event delivery lag, and are monitoring as the delays decrease, and we move towards real-time.
Posted Oct 14, 2025 - 14:38 PDT

Investigating

We are currently seeing delays in event delivery in the EU, our engineering teams have identified and are working to implement a path to resolution.
Posted Oct 14, 2025 - 13:46 PDT
This incident affected: Engage (Engage (EU)).