Delay in Profiles Identity Resolution

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 08:11 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2025 - 06:07 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 27, 2025 - 05:21 PDT

Investigating

We have observed an increase in latency within Engage and are currently investigating the issue. Audience, Computed Trait, and Journey updates may have been delayed by up to two hours.
Posted Jun 27, 2025 - 05:18 PDT
This incident affected: Engage (Engage (US)).