Journeys UI issue

Incident Report for Segment

Resolved

Journeys UI is fully functional now.
Posted Sep 27, 2023 - 15:30 PDT

Identified

We have identified a recent issue with Journeys that prevents the page from loading successfully and are actively working to mitigate it
Posted Sep 27, 2023 - 15:08 PDT
This incident affected: Engage (Engage (US), Engage (EU)).