Accuracy of scores for certain predictive traits

Incident Report for Segment

Resolved

All new model scores have been successfully generated. The Predictions Overview page will automatically update as additional data becomes available for the new predictions. We appreciate your patience as the updated results are reflected.
Posted May 05, 2025 - 11:02 PDT

Monitoring

We have deployed a fix, and the correct model scores are now being generated. Please note that the conversion history on the Predictions Overview page may still display incorrect results; we are actively working to resolve this issue.
Posted May 03, 2025 - 17:13 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 03, 2025 - 10:16 PDT

Investigating

We've identified a bug that is affecting the accuracy of scores for certain predictive traits. This issue may temporarily reduce the performance of those scores. Our engineering team is actively working on a fix and we will provide further updates as progress is made.
Posted May 03, 2025 - 10:13 PDT
This incident affected: Engage (Engage (US), Engage (EU)).