Debugger Sample Rate and Latency Issues

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Aug 07, 2023 - 09:33 PDT

Monitoring

A fix has been implemented and we are monitoring performance of the source debugger.
Posted Jul 28, 2023 - 13:40 PDT

Identified

The debugger system is experiencing significant load, which impacts the sampling rate and latency of events on the Source Debugger. We are working on upgrading the database, but the experience may be degraded. There is no impact to delivery to destinations.
Posted Jun 15, 2023 - 11:57 PDT
This incident affected: Web Interface (Web Interface (US)).