Internal Error in Destination Function event delivery since 12/14
Incident Report for Segment
Resolved
We have resolved the issue for events being discarded due to an "Internal" error. Customers that have seen this error can request to have their data replayed by reaching out to Segment support.
Posted Jan 03, 2024 - 12:58 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 03, 2024 - 10:59 PST
Identified
Since 12/14, a small number of Destination Functions have errantly discarded data. The events will not have been delivered to their source and can be explored in Delivery Overview "filtered at destination" step as "internal" errors.
Posted Jan 03, 2024 - 09:32 PST
This incident affected: Streaming Destinations (Streaming Destinations (US)) and Data Processing Pipeline (Data Processing Pipeline (US)).