Connections delivery time to first attempt is elevated

Incident Report for Segment

Resolved

We've confirmed that the delivery time to first attempt has returned to normal levels.
Posted Nov 10, 2025 - 19:49 PST

Monitoring

We've mitigated the cause of the delays and are actively monitoring as they recovery.
Posted Nov 10, 2025 - 19:32 PST

Identified

We've identified the cause of the delays and are taking steps to mitigate the elevated delays.
Posted Nov 10, 2025 - 17:45 PST

Investigating

Our systems have reported an elevated Time to First Attempt for Connections traffic. We're actively investigating.
Posted Nov 10, 2025 - 17:04 PST
This incident affected: Streaming Destinations (Streaming Destinations (US)).