Delay in profile data processing

Incident Report for Segment

Resolved

This incident has been resolved.
Posted May 03, 2025 - 14:55 PDT

Monitoring

Processing delay is recovering and we are continuing to monitor closely.
Posted May 03, 2025 - 13:46 PDT

Identified

We detected an issue that affected identity resolution and profile data update may be delayed. We have deployed a change to address the issue and are closely monitoring.
Posted May 03, 2025 - 13:18 PDT
This incident affected: Engage (Engage (US)).