Segment Deletion Failures

Incident Report for Segment

Resolved

This incident has now been resolved. All deletion requests are processing successfully
Posted Aug 14, 2025 - 09:20 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 08:29 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 14, 2025 - 08:25 PDT

Update

We are continuing to investigate this issue.
Posted Aug 14, 2025 - 08:21 PDT

Investigating

Segment deletion calls in US and EU environments have started failing from Aug 14th 4:42AM PST. We are currently investigating the issue
Posted Aug 14, 2025 - 08:12 PDT
This incident affected: Data Deletions (Data Deletions (US), Data Deletions (EU)).