Snowflake RETL sources and Warehouse Destinations are failing due to Snowflake Outage

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 08:55 PST

Update

We are continuing to investigate this issue.
Posted Dec 16, 2025 - 00:24 PST

Investigating

We are currently monitoring the issue . Outage is declared here : https://status.snowflake.com/incidents/xdxj4klf7sc5
Posted Dec 15, 2025 - 22:37 PST
This incident affected: Warehouses (Warehouse Destinations (US), Warehouse Destinations (EU)), Reverse ETL (Reverse ETL (EU), Reverse ETL (US)), Linked Events (Linked Events (EU), Linked Events (US)), and Linked Audiences (Linked Audiences (US), Linked Audiences (EU)).