Elevated Event Delivery Latency

Incident Report for Segment

Resolved

This incident has been resolved
Posted Jul 15, 2026 - 11:03 PDT

Monitoring

Systems are recovering, we're actively monitoring.
Posted Jul 15, 2026 - 10:55 PDT

Identified

have identified the root cause and are actively working on a fix.
Posted Jul 15, 2026 - 10:03 PDT

Investigating

We are currently investigating an issue impacting the time to first attempt for Connections event delivery.
Posted Jul 15, 2026 - 09:48 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US)).