Engage & Profile UI Features Not Loading
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 13:32 PDT
Investigating
Engage & Profiles UI features including Audiences, Journeys, and Profiles are currently not loading. No data loss has occurred. The team is currently working on a solution.
Posted Mar 21, 2023 - 11:21 PDT
This incident affected: Engage (Engage (US), Engage (EU)).