Partial Sync Failures for Profiles Sync

Incident Report for Segment

Resolved

We have implemented measures to prevent unintended traits from appearing in profile syncs, and syncs are now running as expected. Our teams are developing a long-term solution and will share guidance with impacted customers on how to address any previously affected data.
Posted Sep 09, 2025 - 14:42 PDT

Identified

Between August 28, 2025, 11:21 AM PT and September 5, 2025, 5:04 AM PT, certain internal computed traits were unintentionally synced to the profile_traits_updates raw table for some specific scenarios. This resulted in partial sync failures for that table because of a breach of the warehouse column limit, which prevented data from being fully written.
To mitigate the issue, we have disabled the syncing of such traits going forward and are actively evaluating next steps to remediate the data that was already synced.
Posted Sep 09, 2025 - 07:23 PDT