Data processing pipeline issue

Incident Report for Segment

Monitoring

A fix has been implemented, and we are actively monitoring the results.
Posted Jul 25, 2026 - 20:02 PDT

Identified

We have identified an issue impacting data processing affecting multiple components.
Posted Jul 25, 2026 - 18:43 PDT
This incident affects: Engage (Engage (US), Journeys (US)) and Data Processing Pipeline (Data Processing Pipeline (US)).