Engage functionality is experiencing degradation and not usable at the moment

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 07:42 PDT

Update

Our engineering teams are actively investigating the root cause and working to restore full functionality. We will provide updates as more information becomes available.
Posted Jun 03, 2025 - 06:54 PDT

Investigating

We are currently investigating this issue.
Posted Jun 03, 2025 - 06:51 PDT
This incident affected: Engage (Engage (US)).