Engage Premier Email Template Creation and Editing Issue
Incident Report for Segment
Resolved
A fix has been implemented, and we are continuing to monitor the result.
Posted Jul 29, 2024 - 09:27 PDT
Investigating
The Segment engineering team has acknowledged an incident affecting customers with Engage Premier. These customers are currently unable to create new email templates or edit existing ones. When attempting to do so, an error message stating "Something went wrong" appears.

We are actively working on resolving this issue and will provide updates as soon as possible. Thank you for your patience.
Posted Jul 29, 2024 - 05:38 PDT
This incident affected: Engage (Engage (US), Engage (EU)).