Some Unify and Engage customers are experiencing inability to create new Audiences and Traits
Incident Report for Segment
Resolved
This incident has been resolved
Posted Dec 05, 2024 - 14:38 PST
Investigating
We are currently investigating this issue.
Posted Dec 05, 2024 - 08:59 PST
This incident affected: Engage (Engage (US)).