Issues with the Identity configuration page for customers who use Personas
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 14:32 PDT
Identified
Our team continues to work to restore the identifier "seen" visibility in the Segment web application. No data has been lost.

Unfortunately restoring this functionality is taking far longer than what customers typically expect from Segment. However, our #1 priority is ensuring that critical customer data is not lost or mishandled. In that spirit, the team is taking a slower, more conservative approach to avoid inadvertently introducing issues with data processing.

Currently we expect that this functionality will be restored for most active customers by 6PM US Pacific Time on July 1st.

We will be expanding our restoration to more customers in the coming weeks, and currently expect to reach completeness by July 21st.
Posted Jun 30, 2020 - 12:24 PDT
Investigating
Some customers who use Personas have been experiencing issues with the identity configuration page. Currently the Segment web application is unable to show which identifiers have been seen. All identifiers appear in the "unseen" state, regardless of their actual status. Customers who do not use Personas functionality are not impacted.

This does not impact the way data is processed inside of Segment. No data has been lost. The problem is entirely with the visibility of this data in the user interface. Our engineering team is currently working to restore this functionality as soon as possible.
Posted Jun 26, 2020 - 17:40 PDT
This incident affected: Engage (Engage (US)).