Facebook Custom Audiences destination is experiencing partial delivery failures for few workspaces

Incident Report for Segment

Monitoring

We've shipped a fix and confirmed that it’s working. We’re going to keep a close eye on things for the next few hours just to be absolutely sure everything is stable.
Posted Jun 08, 2026 - 12:35 PDT

Identified

The root cause has been identified. will be rolling out the fix shortly.
Posted Jun 05, 2026 - 01:13 PDT

Investigating

The root cause has been identified. will be rolling out the fix shortly.
Posted Jun 05, 2026 - 01:11 PDT