Google Enhanced Conversions is experiencing elevated failures

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 18:06 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 17, 2025 - 16:08 PDT

Monitoring

We've mitigated this incident, and impacted customers should start seeing positive results.
Posted Sep 17, 2025 - 15:18 PDT

Identified

We've identified the cause of the forbidden errors and are working on mitigation.
Posted Sep 17, 2025 - 14:58 PDT

Investigating

We're investigating unexpected forbidden errors across multiple customers for the google enhanced conversions destination. We're reaching out to Google for support.
Posted Sep 17, 2025 - 14:37 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US), Streaming Destinations (EU)).