Connections Processing Delays

Incident Report for Segment

Monitoring

A fix has been implemented, and we are actively monitoring the situation as processing latency recovers.
Posted Jul 25, 2026 - 16:39 PDT

Identified

The issue has been identified and we are actively working on mitigation.
Posted Jul 25, 2026 - 16:29 PDT

Investigating

We are currently investigating this issue.
Posted Jul 25, 2026 - 15:45 PDT
This incident affects: Streaming Destinations (Streaming Destinations (US)).