Billing Issues Affecting Credit Card Form
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Jan 09, 2017 - 15:32 PST
Update
The minor billing issue regarding our credit card modal is now solved. Thank you for your patience! As mentioned, no customer data or billing has been affected.
Posted Jan 09, 2017 - 15:31 PST
Investigating
We are currently experiencing a minor billing issue that's preventing our credit card modal from displaying to users. You may not be able to add, edit, or delete your credit card. Our engineers are investigating and will update this page as soon as it's fixed. No customer data has been lost or affected by this issue.
Posted Jan 09, 2017 - 12:02 PST
This incident affected: Web Interface (Web Interface (US)).