Personas audience page failing to load for some customers
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Jul 21, 2022 - 12:47 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2022 - 08:53 PDT
Identified
The issue has been identified and we are working on implementing a fix.
Posted Jul 19, 2022 - 22:15 PDT
This incident affected: Personas (Personas (US)).