Delayed delivery reporting for ReverseETL

Incident Report for Segment

Resolved

We've restored the ReverseETL delivery counts in the US
Posted Nov 04, 2025 - 09:56 PST

Update

We've restored the ReverseETL delivery counts in the EU and are actively working on updating them in the US.
Posted Nov 04, 2025 - 07:51 PST

Update

We’re actively working on retroactively updating the ReverseETL delivery counts for affected customers. All ReverseETL Syncs created after 4 PM PST will correctly report counts.
Posted Nov 03, 2025 - 20:32 PST

Identified

ReverseETL delivery counts are currently delayed. Syncs that started between 6:00 AM and 4:00 PM PST on November 3 may show inaccurate counts or timeout errors. We've identified the issue and are working towards a resolution.

Note: This is only affecting reporting, no data loss or change in delivery.
Posted Nov 03, 2025 - 17:09 PST
This incident affected: Reverse ETL (Reverse ETL (EU), Reverse ETL (US)).