Redshift: "timestamp" values inserted as "_timestamp"
Incident Report for Segment
Resolved
All rows in Redhsift warehouses that were affected by this issue were fixed on a rolling basis throughout the weekend. Only warehouses that ran a sync starting on May 10th from 3PM to 10PM PST were affected by this issue.

The erroneously-added _timestamp columns will be removed over the next few days. You may also drop them yourself or reach out to Segment support to have them dropped immediately, as well.

If you have any concerns or questions, please do not hesitate to reach out to us.
Posted May 15, 2017 - 11:47 PDT
Identified
At 3:54PM PST yesterday, we released a bad update to the Redshift warehouse connector that caused the timestamp property of event messages to populate in a new column, _timestamp instead of the correct timestamp column.

We recognize and honor the importance of the stability of the core schema fields and your reliance on them in your reporting, exploration, and analysis. As such, as soon as soon we diagnosed the issue at 9:50PM, we immediately rolled back the connector and made arrangements to correct the bad data.

We are backfilling the data for the affected window into the original timestamp column. This is our top priority.
Posted May 11, 2017 - 11:13 PDT
This incident affected: Warehouses (Warehouses (US)).