(US West 2) Partial degradation of Linked Audiences, Linked Events, Reverse ETL, and Profile Sync due to external Snowflake Outage

Incident Report for Segment

Resolved

Snowflake outage has resolved and consequently impacted functionalities across segment have recovered as well.
Posted Jun 22, 2026 - 17:22 PDT

Identified

An ongoing upstream outage with Snowflake is causing degraded performance for Segment products that rely on customer data warehouses.

- Impacted Products: Linked Audiences, Linked Events, Reverse ETL, and Profile Sync.
- Current Status: Syncs and data processing may be failing.
- Action Required: None. Data workflows will resume automatically once Snowflake capabilities are restored.
- More Info: Monitor real-time infrastructure updates directly on the Snowflake Status Page: https://status.snowflake.com/
Posted Jun 22, 2026 - 15:14 PDT
This incident affected: Warehouses (Warehouse Destinations (US)), Linked Audiences (Linked Audiences (US)), Reverse ETL (Reverse ETL (US)), and Linked Events (Linked Events (US)).