Customer web interface issue

Incident Report for Segment

Resolved

This incident has been resolved
Posted May 20, 2025 - 16:12 PDT

Monitoring

We are fully back live.
Posted May 20, 2025 - 14:58 PDT

Investigating

We are currently investigating an issue with the Segment web application and public API.
Posted May 20, 2025 - 14:48 PDT
This incident affected: Web Interface (Web Interface (US), Web Interface (EU)) and Public API (Public API (US), Public API (EU)).