Delays delivering some data to downstream destinations

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Mar 21, 2023 - 16:27 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2023 - 15:36 PDT

Update

We are continuing to investigate this issue.
Posted Mar 21, 2023 - 15:33 PDT

Investigating

~2% of customers might be experiencing delays in delivering data to downstream destinations. No data is being lost. our on-call team has identified an issue with faulty node and replaced it.
Posted Mar 21, 2023 - 15:33 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US)).