Delays in data delivery
Incident Report for Segment
Resolved
Data delivery latency has returned to a normal level.
Posted Aug 31, 2021 - 13:02 PDT
Monitoring
We implemented additional mitigation measures are observing data delivery latency trending back down.
Posted Aug 31, 2021 - 12:05 PDT
Identified
On 2021-08-31 10:16 PDT we detected a substantial surge in events traffic that has caused increased delays in delivery of data to destinations through the Segment pipeline. We have identified the cause of the surge and took immediate action to stop the sources producing the data. We are actively working on reducing the increased data delivery delays.
Posted Aug 31, 2021 - 11:23 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US)), Warehouses (Warehouses (US)), and Data Processing Pipeline (Data Processing Pipeline (US)).