Audiences Overview Pages are Failing to Load in the EU

Incident Report for Segment

Resolved

The issue has been resolved, and EU users are now able to access the Audiences overview page in the Segment UI.
Posted Mar 17, 2026 - 12:39 PDT

Investigating

Engineering is currently investigating an issue that is preventing customers in the EU from viewing Audiences overview pages in the Segment UI. This issue is limited to the UI only and does not impact the data plane.
Posted Mar 17, 2026 - 11:55 PDT
This incident affected: Web Interface (Web Interface (EU)).