Delays for Reverse ETL statistics and sync status

Incident Report for Segment

Resolved

The incident is now fully resolved.
Posted Aug 14, 2025 - 23:26 PDT

Monitoring

We are monitoring recovery and expect Reverse ETL delivery statistics to be fully caught up in approximately 6 hours.
Posted Aug 14, 2025 - 21:44 PDT

Identified

Updates to Reverse ETL delivery statistics and sync status have been delayed since approximately 3pm PT on 8/14. Delivery of actual messages is unaffected.
Posted Aug 14, 2025 - 21:36 PDT
This incident affected: Reverse ETL (Reverse ETL (US)).