elevated delivery latency in eu-west-1

Incident Report for Segment

Resolved

After thorough monitoring and analysis, we have determined that this issue did not impact customers.
Posted Oct 09, 2025 - 11:21 PDT

Monitoring

Delays in production in the eu-west-1 region have returned to normal. We're actively monitoring.
Posted Oct 09, 2025 - 10:41 PDT

Investigating

Segment p99 delivery latency is elevated above slightly above 5 minutes. We're actively investigating.
Posted Oct 09, 2025 - 10:09 PDT
This incident affected: Streaming Destinations (Streaming Destinations (EU)).