Personas Data Processing Delays
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 12:02 PDT
Monitoring
A fix has been implemented and we are continuing to monitor the result.
Posted Jun 18, 2021 - 11:44 PDT
This incident affected: Engage (Engage (US)).