Data Processing Delays in EU
Incident Report for Segment
Resolved
We have restored historical data for Schema property analytics data in the EU region. All Event Delivery and Schema analytics data is current since 7:15 2023-03-22 UTC. We incurred data loss in the EU region for Event Delivery from 1:30 UTC - 7:15 UTC.
Posted Mar 22, 2023 - 13:04 PDT
Update
We have restored data through 2023-03-21 23:00:00 UTC for Event Delivery and are working through a backlog to make data current with an ETA of 2 hours. We expect data loss across various metrics for several hours.

There is an ongoing historical data outage on Schema property metric data that we do not have an ETA on recovery.
Posted Mar 22, 2023 - 00:17 PDT
Update
We have restored systems serving data to Event Delivery and Schema metrics and are in the process of backfilling data. Event Delivery and Schema pages will be returning inconsistent data until data restore is completed.
Posted Mar 21, 2023 - 21:13 PDT
Update
Customers in EU will not have accurate Event Delivery and Schema Metrics in the Segment App and Public API. We are working on restoring functionality with no current ETA.
Posted Mar 21, 2023 - 18:37 PDT
Update
We are continuing to monitor for any further issues.
Posted Mar 21, 2023 - 18:32 PDT
Monitoring
We are closely monitoring the issue.
Posted Mar 21, 2023 - 17:24 PDT
Investigating
We are actively investigating the issue in EU region
Posted Mar 21, 2023 - 17:00 PDT
This incident affected: Web Interface (Web Interface (EU)) and Engage (Engage (EU)).