New Signups Currently Disabled
Incident Report for Segment
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 15, 2019 - 13:15 PDT
Identified
We’re experiencing an issue with our sign up flow right now and are working on a fix. To make sure you get access to an account, please fill out this form: (some better flow to get there)https://segment.com/help/contact/ We’ll be in touch shortly.
Posted 4 months ago. Mar 15, 2019 - 12:32 PDT