Clearbit reveal integration is facing delivery issues

Incident Report for Segment

Resolved

All events are flowing through now
Posted Aug 07, 2025 - 12:06 PDT

Monitoring

The delivery endpoint is up now. We are monitoring
Posted Aug 07, 2025 - 12:00 PDT

Identified

Clearbit Reveal integration is facing delivery issues. Clearbit integration endpoint is down. We have reached out to Clearbit for help.
Posted Aug 07, 2025 - 11:57 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US)).