Analytics and Metrics performance may be delayed or fail to load
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Sep 11, 2023 - 18:31 PDT
Identified
UI features related to Event Delivery, Delivery Overview, Audience Builder, and more are continuing to see degraded status. We have identified the issue and are working on a fix.
Posted Sep 11, 2023 - 15:23 PDT
Investigating
Metrics and analytics features within the Segment UI or API's may be delayed or fail to load.
Posted Sep 11, 2023 - 13:04 PDT
This incident affected: Web Interface (Web Interface (US)).