Inconsistent Email Delivery
Incident Report for Segment
Resolved
This incident has been resolved
Posted May 04, 2023 - 08:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2023 - 13:39 PDT
Update
We have isolated the problem to email templates that exceed a certain size and are working towards a solution.
Posted May 03, 2023 - 11:31 PDT
Identified
We have isolated the problem to select workspaces and will continue to monitor the problem as we implement a solution.
Posted May 02, 2023 - 20:22 PDT
Investigating
We are seeing inconsistent delivery of emails in Twilio Engage. We are currently investigating the problem.
Posted May 02, 2023 - 13:49 PDT
This incident affected: Engage (Engage (US)).