Delays in Delivery to Destinations for a subset of events

Incident Report for Segment

Resolved

Delivery latency has returned to normal for all incoming traffic. A small number of events are queued for retry, and will be delivered within the next 15 minutes.
Posted Nov 20, 2025 - 17:21 PST

Monitoring

A subset of events are delayed delivering to destinations by approximately 1 hour. The team has mitigated the root cause, and is monitoring as delivery time returns to normal.
Posted Nov 20, 2025 - 16:38 PST
This incident affected: Streaming Destinations (Streaming Destinations (US)).