Amazon Event Bridge and Amazon Personalize Destinations are experiencing elevated error rates

Incident Report for Segment

Resolved

We've confirmed that the impacted destinations have recovered. All impacted events will automatically be retried. No further action needed.
Posted Apr 07, 2026 - 11:30 PDT

Monitoring

A fix has been implemented, and we are seeing initial signs of recovery. We will continue to monitor the service closely to ensure full stability.
Posted Apr 07, 2026 - 10:37 PDT

Identified

A recent update has been identified as the cause of this issue. We are working on reverting the change.
Posted Apr 07, 2026 - 10:10 PDT

Investigating

Amazon Event Bridge and Amazon Personalize Destinations are experiencing elevated error rates. We are currently investigating the issue. We will provide updates as they become available.
Posted Apr 07, 2026 - 10:07 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US), Streaming Destinations (EU)).