Elevated delivery delays for some customers

Incident Report for Segment

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 08:02 PDT

Monitoring

We've applied a fix and are waiting for traffic to recover.
Posted Oct 02, 2025 - 07:27 PDT

Identified

We've identified delivery delays of up to 10 minutes for some customers.
Posted Oct 02, 2025 - 06:35 PDT
This incident affected: Streaming Destinations (Streaming Destinations (US)).