App unavailable
Incident Report for Segment
Resolved
This incident has been resolved.
Posted Dec 15, 2020 - 17:36 PST
Investigating
We are currently investigating this issue.
Posted Dec 15, 2020 - 17:01 PST
This incident affected: Web Interface.